NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

contao/core Insufficient input validation allows for code injection and remote executionGHSA-wxxw-5gq6-j2g5

CRITICALFix: contao/core@d455035

GHSA-wxxw-5gq6-j2g5 is a critical-severity (CVSS 9) remote code execution vulnerability in contao/core. A fix is available for contao/core — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘contao/core🐘contao/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcontao/core≥ 2.0.0&&< 2.11.172.11.17composer require contao/core:^2.11.17
🐘Packagistcontao/core≥ 3.0.0&&< 3.2.93.2.9composer require contao/core:^3.2.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update contao/core to 2.11.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wxxw-5gq6-j2g5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.
O3 Security · Impact-Aware SCA

Is GHSA-wxxw-5gq6-j2g5 in your dependencies?

Find it across Packagist, including transitive dependencies.

contao/core Insufficient input validation allows for code…