NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2016-4567 — mediaelement

MEDIUMFix: johndyer/mediaelement@34834ee

CVE-2016-4567 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mediaelement. A fix is available for mediaelement — see the affected versions and patch details below.

MediaElement Vulnerable to Reflected XSS

Also known asGHSA-277w-qpxr-2549
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
3.20%4.90%6.61%8.31%4.2%7.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

51other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mediaelementnpm
24Kdownloads / week

Description

Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmmediaelementall versions2.11.1npm install mediaelement@2.11.1
🐘Packagistcontao-components/mediaelement≥ 2.14.2&&< 2.21.12.21.1composer require contao-components/mediaelement:^2.21.1
🐘Packagistcontao/core≥ 3.0.0&&< 3.5.153.5.15composer require contao/core:^3.5.15

Affected Products

2 products · 2 configurations
Application
mediaelement.jsmediaelementjs
≤ 2.20.1
range
Application
wordpresswordpress
≤ 4.5.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediaelement, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediaelement to 2.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4567 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
O3 Security · Impact-Aware SCA

Is CVE-2016-4567 in your dependencies?

Find it across npm, Packagist, including transitive dependencies.

CVE-2016-4567: mediaelement XSS — Fixed in 2.11.1