CVE-2019-10641 is a critical-severity (CVSS 9.8) CWE-640 vulnerability in contao/contao. A fix is available for contao/contao — see the affected versions and patch details below.
Contao Does Not Invalidate Existing Sessions When Password Changes
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/contao🐘contao/contao🐘contao/core-bundle🐘contao/core-bundle🐘contao/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Security researcher Ali Razzaq has discovered that existing sessions are not correctly invalidated when a user changes their password in the backend or frontend.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/contao | ≥ 4.0.0&&< 4.4.37 | 4.4.37composer require contao/contao:^4.4.37 |
| 🐘Packagist | contao/contao | ≥ 4.5.0&&< 4.7.3 | 4.7.3composer require contao/contao:^4.7.3 |
| 🐘Packagist | contao/core-bundle | ≥ 4.0.0&&< 4.4.37 | 4.4.37composer require contao/core-bundle:^4.4.37 |
| 🐘Packagist | contao/core-bundle | ≥ 4.5.0&&< 4.7.3 | 4.7.3composer require contao/core-bundle:^4.7.3 |
| 🐘Packagist | contao/core | ≥ 3.0.0&&< 3.5.39 | 3.5.39composer require contao/core:^3.5.39 |
Affected Products
contao cmscontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/contao, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/contao to 4.4.37 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10641 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-10641 in your dependencies?
Find it across Packagist, including transitive dependencies.