NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-29200 — contao

MEDIUMFix: contao/contao@6f3e705

CVE-2023-29200 is a medium-severity (CVSS 4.3) Path Traversal vulnerability in contao/contao. A fix is available for contao/contao — see the affected versions and patch details below.

contao/core-bundle has path traversal vulnerability in the file manager

Also known asGHSA-fp7q-xhhw-6rj3
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-29200.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.08%0.48%0.89%1.30%0.6%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘contao/contao🐘contao/contao🐘contao/contao

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Contao is an open source content management system. Prior to versions 4.9.40, 4.13.21, and 5.1.4, logged in users can list arbitrary system files in the file manager by manipulating the Ajax request. However, it is not possible to read the contents of these files. Users should update to Contao 4.9.40, 4.13.21 or 5.1.4 to receive a patch. There are no known workarounds.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcontao/contao≥ 4.9.0&&< 4.9.404.9.40composer require contao/contao:^4.9.40
🐘Packagistcontao/contao≥ 4.13.0&&< 4.13.214.13.21composer require contao/contao:^4.13.21
🐘Packagistcontao/contao≥ 5.1.0&&< 5.1.45.1.4composer require contao/contao:^5.1.4

Affected Products

1 product · 3 configurations
Application
contaocontao
≥ 5.0.0 && < 5.1.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/contao, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update contao/contao to 4.9.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-29200 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Contao is an open source content management system. Prior to versions 4.9.40, 4.13.21, and 5.1.4, logged in users can list arbitrary system files in the file manager by manipulating the Ajax request. However, it is not possible to read the contents of these files. Users should update to Contao 4.9.40, 4.13.21 or 5.1.4 to receive a patch. There are no known workarounds.
O3 Security · Impact-Aware SCA

Is CVE-2023-29200 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-29200: contao — Fixed in 4.9.40