NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2025-57758 — core-bundle

MEDIUMFix: contao/contao@3f05c60

CVE-2025-57758 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in contao/core-bundle. A fix is available for contao/core-bundle — see the affected versions and patch details below.

Contao has improper access control in the back end voters

Also known asGHSA-7m47-r75r-cx8v
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-57758.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.25%0.50%0.76%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘contao/core-bundle🐘contao/core-bundle🐘contao/contao🐘contao/contao

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The table access voter in the back end doesn't check if a user is allowed to access the corresponding module.

Patches

Update to Contao 5.3.38 or 5.6.1.

Workarounds

Do not rely solely on the voter and additionally check USER_CAN_ACCESS_MODULE.

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcontao/core-bundle≥ 5.0.0&&< 5.3.385.3.38composer require contao/core-bundle:^5.3.38
🐘Packagistcontao/core-bundle≥ 5.4.0-RC1&&< 5.6.15.6.1composer require contao/core-bundle:^5.6.1
🐘Packagistcontao/contao≥ 5.0.0&&< 5.3.385.3.38composer require contao/contao:^5.3.38
🐘Packagistcontao/contao≥ 5.4.0-RC1&&< 5.6.15.6.1composer require contao/contao:^5.6.1

Affected Products

1 product · 2 configurations
Application
contaocontao
≥ 5.4.0 && < 5.6.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update contao/core-bundle to 5.3.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-57758 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact The table access voter in the back end doesn't check if a user is allowed to access the corresponding module. ### Patches Update to Contao 5.3.38 or 5.6.1. ### Workarounds Do not rely solely on the voter and additionally check `USER_CAN_ACCESS_MODULE`. ### For more information If you have any questions or comments about this advisory, open an issue in [contao/contao](https://github.com/contao/contao/issues/new/choose).
O3 Security · Impact-Aware SCA

Is CVE-2025-57758 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-57758: core-bundle — Fixed in 5.3.38