CVE-2025-57756 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in contao/core-bundle. A fix is available for contao/core-bundle — see the affected versions and patch details below.
Contao discloses sensitive information in the front end search index
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-57756.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/core-bundle🐘contao/contao🐘contao/core-bundle🐘contao/core-bundle🐘contao/contao🐘contao/contaoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Contao is an Open Source CMS. In versions starting from 4.9.14 and prior to 4.13.56, 5.3.38, and 5.6.1, protected content elements that are rendered as fragments are indexed and become publicly available in the front end search. This issue has been patched in versions 4.13.56, 5.3.38, and 5.6.1. A workaround involves disabling the front end search.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/core-bundle | ≥ 4.9.14&&< 4.13.56 | 4.13.56composer require contao/core-bundle:^4.13.56 |
| 🐘Packagist | contao/contao | ≥ 4.9.14&&< 4.13.56 | 4.13.56composer require contao/contao:^4.13.56 |
| 🐘Packagist | contao/core-bundle | ≥ 5.0.0-RC1&&< 5.3.38 | 5.3.38composer require contao/core-bundle:^5.3.38 |
| 🐘Packagist | contao/core-bundle | ≥ 5.4.0-RC1&&< 5.6.1 | 5.6.1composer require contao/core-bundle:^5.6.1 |
| 🐘Packagist | contao/contao | ≥ 5.0.0-RC1&&< 5.3.38 | 5.3.38composer require contao/contao:^5.3.38 |
| 🐘Packagist | contao/contao | ≥ 5.4.0-RC1&&< 5.6.1 | 5.6.1composer require contao/contao:^5.6.1 |
Affected Products
contaocontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/core-bundle to 4.13.56 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-57756 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2025-57756 in your dependencies?
Find it across Packagist, including transitive dependencies.