CVE-2015-0269 is a medium-severity (CVSS 4.3) Path Traversal vulnerability in contao/core. A fix is available for contao/core — see the affected versions and patch details below.
Contao Core directory traversal vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/core🐘contao/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Directory traversal vulnerability in Contao before 3.2.19, and 3.4.x before 3.4.4 allows remote authenticated "back end" users to view files outside their file mounts or the document root via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/core | ≥ 3.4.0&&< 3.4.4 | 3.4.4composer require contao/core:^3.4.4 |
| 🐘Packagist | contao/core | ≥ 2.0.0&&< 3.2.19 | 3.2.19composer require contao/core:^3.2.19 |
Affected Products
contao cmscontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/core to 3.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0269 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2015-0269 in your dependencies?
Find it across Packagist, including transitive dependencies.