NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-10993 — contao

HIGH

CVE-2017-10993 is a high-severity (CVSS 8.8) Path Traversal vulnerability in contao/contao. A fix is available for contao/contao — see the affected versions and patch details below.

Contao Core directory traversal vulnerability

Also known asGHSA-x5g4-crxq-qxjx
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.26%1.27%2.28%3.29%0.8%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘contao/contao🐘contao/core-bundle🐘contao/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A logged in back end user can include arbitrary PHP files by manipulating an URL parameter. Since Contao does not allow to upload PHP files in the file manager, the attack is limited to the existing PHP files on the server.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcontao/contao≥ 4.0.0&&< 4.4.14.4.1composer require contao/contao:^4.4.1
🐘Packagistcontao/core-bundle≥ 4.0.0&&< 4.4.14.4.1composer require contao/core-bundle:^4.4.1
🐘Packagistcontao/core≥ 3.0.0&&< 3.5.283.5.28composer require contao/core:^3.5.28

Affected Products

1 product · 38 configurations
Application
contao cmscontao
≤ 3.5.27
27 versions
4.0.04.0.14.0.24.0.34.0.44.1.04.1.14.1.24.1.34.2.04.2.14.2.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/contao, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update contao/contao to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-10993 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

A logged in back end user can include arbitrary PHP files by manipulating an URL parameter. Since Contao does not allow to upload PHP files in the file manager, the attack is limited to the existing PHP files on the server.
O3 Security · Impact-Aware SCA

Is CVE-2017-10993 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-10993: contao — Fixed in 4.4.1