Contao Core directory traversal vulnerabilityGHSA-x5g4-crxq-qxjx
HIGHGHSA-x5g4-crxq-qxjx is a high-severity (CVSS 8.8) Path Traversal vulnerability in contao/contao. A fix is available for contao/contao — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/contao🐘contao/core-bundle🐘contao/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A logged in back end user can include arbitrary PHP files by manipulating an URL parameter. Since Contao does not allow to upload PHP files in the file manager, the attack is limited to the existing PHP files on the server.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/contao | ≥ 4.0.0&&< 4.4.1 | 4.4.1composer require contao/contao:^4.4.1 |
| 🐘Packagist | contao/core-bundle | ≥ 4.0.0&&< 4.4.1 | 4.4.1composer require contao/core-bundle:^4.4.1 |
| 🐘Packagist | contao/core | ≥ 3.0.0&&< 3.5.28 | 3.5.28composer require contao/core:^3.5.28 |
Affected Products
contao cmscontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/contao, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/contao to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x5g4-crxq-qxjx is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-x5g4-crxq-qxjx in your dependencies?
Find it across Packagist, including transitive dependencies.