contao/core PHP object injection vulnerability allows for arbitrary code executionGHSA-wq43-8r5p-w3mc
Fix: contao/core@d67c46cGHSA-wq43-8r5p-w3mc is a remote code execution vulnerability in contao/core. A fix is available for contao/core — see the affected versions and patch details below.
Real-World Exposure
contao/core🐘contao/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
PHP object injection vulnerability was identified in contao/core due to untrusted data being passed to deserialize() function.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/core | ≥ 2.0.0&&< 2.11.14 | 2.11.14composer require contao/core:^2.11.14 |
| 🐘Packagist | contao/core | ≥ 3.0.0&&< 3.2.5 | 3.2.5composer require contao/core:^3.2.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/core to 2.11.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wq43-8r5p-w3mc is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-wq43-8r5p-w3mc in your dependencies?
Find it across Packagist, including transitive dependencies.