ZendFramework1 Potential Security Issues in Bundled Dojo LibraryGHSA-w5mj-j45q-m638
GHSA-w5mj-j45q-m638 is a security vulnerability in zendframework/zendframework1. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.
Real-World Exposure
zendframework/zendframework1🐘zendframework/zendframework1Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In mid-March, 2010, the Dojo Foundation issued a Security Advisory indicating potential security issues with specific files in Dojo Toolkit. Details of the advisory may be found on the Dojo website:
http://dojotoolkit.org/blog/post/dylan/2010/03/dojo-security-advisory/ In particular, several files in the Dojo tree were identified as having potential exploits, and the Dojo team also advised disabling or removing any PHP scripts in the tree when deploying to production.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.9.0&&< 1.9.8 | 1.9.8composer require zendframework/zendframework1:^1.9.8 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.10.0&&< 1.10.3 | 1.10.3composer require zendframework/zendframework1:^1.10.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework1 to 1.9.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w5mj-j45q-m638 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-w5mj-j45q-m638 in your dependencies?
Find it across Packagist, including transitive dependencies.