Zend_Filter_StripTags vulnerable to Cross-site Scripting when comments allowedGHSA-4vf6-mq7w-3hp6
MEDIUMGHSA-4vf6-mq7w-3hp6 is a medium-severity (CVSS 6.1) vulnerability in zendframework/zendframework1. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.
Real-World Exposure
zendframework/zendframework1🐘zendframework/zendframework1🐘zendframework/zendframework1Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Zend_Filter_StripTags contained an optional setting to allow whitelisting HTML comments in filtered text. Microsoft Internet Explorer and several other browsers allow developers to create conditional functionality via HTML comments, including execution of script events and rendering of additional commented markup. By allowing whitelisting of HTML comments, a malicious user could potentially include XSS exploits within HTML comments that would then be rendered in the final output.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.7.0&&< 1.7.9 | 1.7.9composer require zendframework/zendframework1:^1.7.9 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.8.0&&< 1.8.5 | 1.8.5composer require zendframework/zendframework1:^1.8.5 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.9.0&&< 1.9.7 | 1.9.7composer require zendframework/zendframework1:^1.9.7 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework1 to 1.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4vf6-mq7w-3hp6 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-4vf6-mq7w-3hp6 in your dependencies?
Find it across Packagist, including transitive dependencies.