Zendframework potential Cross-site Scripting vector in `Zend_Service_ReCaptcha_MailHide`GHSA-4v57-pwvf-x35j
MEDIUMGHSA-4v57-pwvf-x35j is a medium-severity (CVSS 6.1) vulnerability in zendframework/zendframework1. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.
Real-World Exposure
zendframework/zendframework1🐘zendframework/zendframework1🐘zendframework/zendframework1Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Zend_Service_ReCaptcha_MailHide had a potential XSS vulnerability. Due to the fact that the email address was never validated, and because its use of htmlentities() did not include the encoding argument, it was potentially possible for a malicious user aware of the issue to inject a specially crafted multibyte string as an attack via the CAPTCHA's email argument
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.7.0&&< 1.7.9 | 1.7.9composer require zendframework/zendframework1:^1.7.9 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.8.0&&< 1.8.5 | 1.8.5composer require zendframework/zendframework1:^1.8.5 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.9.0&&< 1.9.7 | 1.9.7composer require zendframework/zendframework1:^1.9.7 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework1 to 1.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4v57-pwvf-x35j is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-4v57-pwvf-x35j in your dependencies?
Find it across Packagist, including transitive dependencies.