NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

Apache Camel data exposure vulnerabilityGHSA-qpxm-689r-3849

LOW

GHSA-qpxm-689r-3849 is a low-severity (CVSS 2.9) CWE-922 vulnerability in org.apache.camel:camel-core. A fix is available for org.apache.camel:camel-core — see the affected versions and patch details below.

Also known asCVE-2024-22371
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-qpxm-689r-3849.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.19%0.58%0.97%1.35%0.9%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.camel:camel-core☕org.apache.camel:camel-core☕org.apache.camel:camel-core☕org.apache.camel:camel-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel. This issue affects Apache Camel: from 3.0.0 through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0.

Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.camel:camel-core≥ 3.0.0&&< 3.21.43.21.4org.apache.camel:camel-core:3.21.4
☕Mavenorg.apache.camel:camel-core≥ 3.22.0&&< 3.22.13.22.1org.apache.camel:camel-core:3.22.1
☕Mavenorg.apache.camel:camel-core≥ 4.0.0&&< 4.0.44.0.4org.apache.camel:camel-core:4.0.4
☕Mavenorg.apache.camel:camel-core≥ 4.1.0&&< 4.4.04.4.0org.apache.camel:camel-core:4.4.0

Affected Products

1 product · 4 configurations
Application
camelapache
≥ 4.1.0 && < 4.4.0
1 version
3.22.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.camel:camel-core to 3.21.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qpxm-689r-3849 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-qpxm-689r-3849 (CC BY 4.0)
ProductFixed inAdvisory
RHOSS-1.33-RHEL-8openshift-serverless-1/logic-data-index-ephemeral-rhel8:1.33.0-5RHSA-2024:4057

Frequently Asked Questions

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel. This issue affects Apache Camel: from 3.0.0 through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
O3 Security · Impact-Aware SCA

Is GHSA-qpxm-689r-3849 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Camel data exposure vulnerability (Low 2.9)