NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-0002 — camel-core

Fix: apache/camel@2ec54fa

CVE-2014-0002 is a CWE-264 vulnerability in org.apache.camel:camel-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.camel:camel-core — see the affected versions and patch details below.

Apache Camel's XSLT component allows remote attackers to read arbitrary files

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
27.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
25.8%28.6%31.3%34.1%28.7%27.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.camel:camel-core☕org.apache.camel:camel-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The XSLT component in Apache Camel before 2.11.4 and 2.12.x before 2.12.3 allows remote attackers to read arbitrary files and possibly have other unspecified impact via an XML document containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.camel:camel-coreall versions2.11.4org.apache.camel:camel-core:2.11.4
☕Mavenorg.apache.camel:camel-core≥ 2.12.0&&< 2.12.32.12.3org.apache.camel:camel-core:2.12.3

Affected Products

1 product · 31 configurations
Application
camelapache
≤ 2.11.3
27 versions
1.0.01.1.01.2.01.3.01.4.01.5.01.6.01.6.11.6.21.6.31.6.42.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.camel:camel-core to 2.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0002 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Fuse ESB Enterprise 7.1.0see advisoryRHSA-2014:0452
Red Hat JBoss A-MQ 6.0see advisoryRHSA-2014:0323
Red Hat JBoss BPMS 6.0camelRHSA-2014:0371
Red Hat JBoss BRMS 6.0camelRHSA-2014:0372
Red Hat JBoss Fuse Service Works 6.0camelRHSA-2014:0459

Frequently Asked Questions

The XSLT component in Apache Camel before 2.11.4 and 2.12.x before 2.12.3 allows remote attackers to read arbitrary files and possibly have other unspecified impact via an XML document containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
O3 Security · Impact-Aware SCA

Is CVE-2014-0002 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-0002: camel-core XXE — Fixed in 2.11.4