CVE-2013-4330 — camel-core
Fix: apache/camel@2281b1fCVE-2013-4330 is a Code Injection vulnerability in org.apache.camel:camel-core. A fix is available for org.apache.camel:camel-core — see the affected versions and patch details below.
Improper Control of Generation of Code in Apache Camel
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.camel:camel-core☕org.apache.camel:camel-core☕org.apache.camel:camel-core☕org.apache.camel:camel-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Camel before 2.9.7, 2.10.0 before 2.10.7, 2.11.0 before 2.11.2, and 2.12.0 allows remote attackers to execute arbitrary simple language expressions by including "$simple{}" in a CamelFileName message header to a (1) FILE or (2) FTP producer.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.camel:camel-core | all versions | 2.9.7org.apache.camel:camel-core:2.9.7 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.10.0&&< 2.10.7 | 2.10.7org.apache.camel:camel-core:2.10.7 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.11.0&&< 2.11.2 | 2.11.2org.apache.camel:camel-core:2.11.2 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.12.0&&< 2.12.1 | 2.12.1org.apache.camel:camel-core:2.12.1 |
Affected Products
camelapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.camel:camel-core to 2.9.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4330 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Fuse ESB Enterprise 7.1.0 | see advisory | RHSA-2013:1862 |
| Red Hat JBoss A-MQ 6.0 | see advisory | RHSA-2013:1410 |
| Red Hat JBoss BPMS 6.0 | camel | RHSA-2014:0140 |
| Red Hat JBoss Fuse Service Works 6.0 | camel | RHSA-2014:0124 |
| Red Hat OpenShift Enterprise 2.0 | activemq-0:5.9.0-4.redhat.610328.el6op | RHSA-2014:0245 |
| RHEL 6 Version of OpenShift Enterprise 1.2 | activemq-0:5.9.0-4.redhat.610328.el6op | RHSA-2014:0254 |
Frequently Asked Questions
Is CVE-2013-4330 in your dependencies?
Find it across Maven, including transitive dependencies.