CVE-2019-0194 is a high-severity (CVSS 7.5) Path Traversal vulnerability in org.apache.camel:camel-core. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.camel:camel-core — see the affected versions and patch details below.
Path Traversal in Apache Camel
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.camel:camel-core☕org.apache.camel:camel-core☕org.apache.camel:camel-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.camel:camel-core | ≥ 2.21.0&&< 2.21.5 | 2.21.5org.apache.camel:camel-core:2.21.5 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.22.0&&< 2.22.3 | 2.22.3org.apache.camel:camel-core:2.22.3 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.23.0&&< 2.23.1 | 2.23.1org.apache.camel:camel-core:2.23.1 |
Affected Products
camelapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 t…
Report on lists.apache.org
Report on lists.apache.org
Report on lists.apache.org
Report on openwall.com
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.camel:camel-core to 2.21.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-0194 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Frequently Asked Questions
Is CVE-2019-0194 in your dependencies?
Find it across Maven, including transitive dependencies.