CVE-2015-0263 — camel-core
Fix: apache/camel@06db9e0CVE-2015-0263 is a security vulnerability in org.apache.camel:camel-core. A fix is available for org.apache.camel:camel-core — see the affected versions and patch details below.
Apache Camel XML External Entity vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.camel:camel-core☕org.apache.camel:camel-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XML external entity (XXE) vulnerability in the XML converter setup in converter/jaxp/XmlConverter.java in Apache Camel before 2.13.4 and 2.14.x before 2.14.2 allows remote attackers to read arbitrary files via an external entity in an SAXSource.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.camel:camel-core | all versions | 2.13.4org.apache.camel:camel-core:2.13.4 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.14.0&&< 2.14.2 | 2.14.2org.apache.camel:camel-core:2.14.2 |
Affected Products
camelapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.camel:camel-core to 2.13.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0263 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.1 | see advisory | RHSA-2015:1041 |
| Red Hat JBoss BPMS 6.0 | camel | RHSA-2015:1539 |
| Red Hat JBoss BRMS 6.0 | camel | RHSA-2015:1538 |
| Red Hat JBoss Fuse Service Works 6.2 | camel | RHSA-2015:2558 |
Frequently Asked Questions
Is CVE-2015-0263 in your dependencies?
Find it across Maven, including transitive dependencies.