NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-11971 — camel

HIGHFix: apache/camel@b954402

CVE-2020-11971 is a high-severity (CVSS 7.5) vulnerability in org.apache.camel:camel. EPSS puts its 30-day exploitation probability at 14.0% (97th percentile). A fix is available for org.apache.camel:camel — see the affected versions and patch details below.

Improper Input Validation in Apache Camel

Also known asGHSA-hfg5-xpvw-c9x4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
14.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
8.31%10.8%13.3%15.7%9.7%14.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.camel:camel☕org.apache.camel:camel-core☕org.apache.camel:camel-management

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Camel's JMX is vulnerable to Rebind Flaw. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.x, 3.0.0 up to 3.1.0 is affected. Users should upgrade to 3.2.0.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.camel:camelall versions3.2.0org.apache.camel:camel:3.2.0
☕Mavenorg.apache.camel:camel-coreall versions3.2.0org.apache.camel:camel-core:3.2.0
☕Mavenorg.apache.camel:camel-managementall versions3.2.0org.apache.camel:camel-management:3.2.0

Affected Products

5 products · 8 configurations
Application
camelapache
≥ 2.22.0 && ≤ 3.1.0
range
Application
communications diameter intelligence huboracle
≥ 8.2.0 && ≤ 8.2.3
range
Application
communications diameter signaling routeroracle
≥ 8.0.0 && ≤ 8.2.2
range
Application
enterprise manager base platformoracle
2 versions
13.3.0.013.4.0.0
Application
flexcube private bankingoracle
2 versions
12.0.012.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.camel:camel to 3.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-11971 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
The JMX instrumentation agent is the vulnerable component in this, if not being used it can be disabled in the following ways * As a Java system property - `-Dorg.apache.camel.jmx.disabled=true` as java system property * Using the CamelContext method - ```java CamelContext camel = new DefaultCamelContext(); camel.disableJMX(); ``` * If using spring altering the spring configuration - ```xml <camelContext id="camel" xmlns="http://camel.apache.org/schema/spring"> <jmxAgent id="agent" disabled="true"/> ... </camelContext> ```
Source: Red Hat security advisory for CVE-2020-11971 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Fuse 7.8.0camel-coreRHSA-2020:5568

Frequently Asked Questions

Apache Camel's JMX is vulnerable to Rebind Flaw. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.x, 3.0.0 up to 3.1.0 is affected. Users should upgrade to 3.2.0.
O3 Security · Impact-Aware SCA

Is CVE-2020-11971 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-11971: camel — Fixed in 3.2.0