CVE-2014-0003 — camel-core
Fix: apache/camel@483b445CVE-2014-0003 is a CWE-264 vulnerability in org.apache.camel:camel-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.camel:camel-core — see the affected versions and patch details below.
Apache Camel's XSLT component allows remote attackers to execute arbitrary Java methods
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.camel:camel-core☕org.apache.camel:camel-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.camel:camel-core | ≥ 2.11.0&&< 2.11.4 | 2.11.4org.apache.camel:camel-core:2.11.4 |
| ☕Maven | org.apache.camel:camel-core | ≥ 2.12.0&&< 2.12.3 | 2.12.3org.apache.camel:camel-core:2.12.3 |
Affected Products
camelapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.camel:camel-core to 2.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0003 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Fuse ESB Enterprise 7.1.0 | see advisory | RHSA-2014:0452 |
| Red Hat JBoss A-MQ 6.0 | see advisory | RHSA-2014:0323 |
| Red Hat JBoss BPMS 6.0 | camel | RHSA-2014:0371 |
| Red Hat JBoss BRMS 6.0 | camel | RHSA-2014:0372 |
| Red Hat JBoss Fuse Service Works 6.0 | camel | RHSA-2014:0459 |
| Red Hat OpenShift Enterprise 2.0 | activemq-0:5.9.0-4.redhat.610328.el6op | RHSA-2014:0245 |
| RHEL 6 Version of OpenShift Enterprise 1.2 | activemq-0:5.9.0-4.redhat.610328.el6op | RHSA-2014:0254 |
Frequently Asked Questions
Is CVE-2014-0003 in your dependencies?
Find it across Maven, including transitive dependencies.