Possible to circumvent title-blacklistGHSA-pjv5-vv93-p648
MEDIUMGHSA-pjv5-vv93-p648 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in mediawiki/core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mediawiki/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.6 | 1.31.6composer require mediawiki/core:^1.31.6 |
| 🐘Packagist | mediawiki/core | ≥ 1.32.0&&< 1.32.6 | 1.32.6composer require mediawiki/core:^1.32.6 |
| 🐘Packagist | mediawiki/core | ≥ 1.33.0&&< 1.33.2 | 1.33.2composer require mediawiki/core:^1.33.2 |
| 🐘Packagist | mediawiki/core | ≥ 1.33.99&&< 1.34.0 | 1.34.0composer require mediawiki/core:^1.34.0 |
Affected Products
debian linuxdebianmediawikimediawikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.31.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pjv5-vv93-p648 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is GHSA-pjv5-vv93-p648 in your dependencies?
Find it across Packagist, including transitive dependencies.