NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2019-12473 — core

HIGH

CVE-2019-12473 is a high-severity (CVSS 7.5) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.

Wikimedia Potential DOS due to slow WatchedItemStore::countVisitingWatchersMultiple

Also known asGHSA-33xw-x3pr-rvqj
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.95%1.91%2.86%0.5%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Wikimedia MediaWiki 1.27.0 through 1.32.1 might allow DoS. Passing invalid titles to the API could cause a DoS by querying the entire watchlist table. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/core≥ 1.27.0&&< 1.27.61.27.6composer require mediawiki/core:^1.27.6
🐘Packagistmediawiki/core≥ 1.30.0&&< 1.30.21.30.2composer require mediawiki/core:^1.30.2
🐘Packagistmediawiki/core≥ 1.31.0&&< 1.31.21.31.2composer require mediawiki/core:^1.31.2
🐘Packagistmediawiki/core≥ 1.32.0&&< 1.32.21.32.2composer require mediawiki/core:^1.32.2

Affected Products

2 products · 5 configurations
OS
debian linuxdebian
1 version
9.0
Application
mediawikimediawiki
≥ 1.32.0 && < 1.32.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/core to 1.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12473 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Wikimedia MediaWiki 1.27.0 through 1.32.1 might allow DoS. Passing invalid titles to the API could cause a DoS by querying the entire watchlist table. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
O3 Security · Impact-Aware SCA

Is CVE-2019-12473 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-12473: core DoS — Fixed in 1.27.6