CVE-2019-12467 — core
MEDIUMCVE-2019-12467 is a medium-severity (CVSS 5.3) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.
MediaWiki Incorrect Access Control vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | all versions | 1.27.6composer require mediawiki/core:^1.27.6 |
| 🐘Packagist | mediawiki/core | ≥ 1.30.0&&< 1.30.2 | 1.30.2composer require mediawiki/core:^1.30.2 |
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.2 | 1.31.2composer require mediawiki/core:^1.31.2 |
| 🐘Packagist | mediawiki/core | ≥ 1.32.0&&< 1.32.2 | 1.32.2composer require mediawiki/core:^1.32.2 |
Affected Products
debian linuxdebianmediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12467 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2019-12467 in your dependencies?
Find it across Packagist, including transitive dependencies.