CVE-2020-25815 — core
MEDIUMCVE-2020-25815 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.
MediaWiki Cross-site Scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.32.0&&< 1.34.3 | 1.34.3composer require mediawiki/core:^1.34.3 |
| 🐘Packagist | mediawiki/core | ≥ 1.35.0-rc.0&&< 1.35.0 | 1.35.0composer require mediawiki/core:^1.35.0 |
Affected Products
fedorafedoraprojectmediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.34.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25815 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-25815 in your dependencies?
Find it across Packagist, including transitive dependencies.