NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-12471 — core

MEDIUM

CVE-2019-12471 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.

MediaWiki Cross-site Scripting (XSS)

Also known asGHSA-2rm7-xxx8-35jh
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.60%1.19%1.79%0.4%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/core≥ 1.27.0&&< 1.27.61.27.6composer require mediawiki/core:^1.27.6
🐘Packagistmediawiki/core≥ 1.30.0&&< 1.30.21.30.2composer require mediawiki/core:^1.30.2
🐘Packagistmediawiki/core≥ 1.31.0&&< 1.31.21.31.2composer require mediawiki/core:^1.31.2

Affected Products

2 products · 4 configurations
OS
debian linuxdebian
1 version
9.0
Application
mediawikimediawiki
≥ 1.32.0 && < 1.32.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/core to 1.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12471 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
O3 Security · Impact-Aware SCA

Is CVE-2019-12471 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-12471: core XSS — Fixed in 1.27.6