MediaWiki Cross-site Scripting (XSS)GHSA-2rm7-xxx8-35jh
MEDIUMGHSA-2rm7-xxx8-35jh is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.27.0&&< 1.27.6 | 1.27.6composer require mediawiki/core:^1.27.6 |
| 🐘Packagist | mediawiki/core | ≥ 1.30.0&&< 1.30.2 | 1.30.2composer require mediawiki/core:^1.30.2 |
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.2 | 1.31.2composer require mediawiki/core:^1.31.2 |
Affected Products
debian linuxdebianmediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2rm7-xxx8-35jh is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-2rm7-xxx8-35jh in your dependencies?
Find it across Packagist, including transitive dependencies.