NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-25814 — core

MEDIUM

CVE-2020-25814 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.

MediaWiki Cross-site Scripting (XSS) vulnerability

Also known asBIT-mediawiki-2020-25814GHSA-4vr7-m8p8-434h
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.62%1.24%1.86%0.3%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/core≥ 1.31.0&&< 1.31.91.31.9composer require mediawiki/core:^1.31.9
🐘Packagistmediawiki/core≥ 1.32.0&&< 1.34.31.34.3composer require mediawiki/core:^1.34.3
🐘Packagistmediawiki/core≥ 1.35.0-rc.0&&< 1.35.01.35.0composer require mediawiki/core:^1.35.0

Affected Products

2 products · 3 configurations
OS
fedorafedoraproject
1 version
33
Application
mediawikimediawiki
≥ 1.32.0 && < 1.34.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/core to 1.31.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25814 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.
O3 Security · Impact-Aware SCA

Is CVE-2020-25814 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-25814: core XSS — Fixed in 1.31.9