NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-19709 — core

MEDIUM

CVE-2019-19709 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in mediawiki/core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mediawiki/core — see the affected versions and patch details below.

Possible to circumvent title-blacklist

Also known asGHSA-pjv5-vv93-p648
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.69%1.38%2.06%0.3%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/core≥ 1.31.0&&< 1.31.61.31.6composer require mediawiki/core:^1.31.6
🐘Packagistmediawiki/core≥ 1.32.0&&< 1.32.61.32.6composer require mediawiki/core:^1.32.6
🐘Packagistmediawiki/core≥ 1.33.0&&< 1.33.21.33.2composer require mediawiki/core:^1.33.2
🐘Packagistmediawiki/core≥ 1.33.99&&< 1.34.01.34.0composer require mediawiki/core:^1.34.0

Affected Products

2 products · 3 configurations
OS
debian linuxdebian
2 versions
9.010.0
Application
mediawikimediawiki
≤ 1.33.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/core to 1.31.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-19709 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.
O3 Security · Impact-Aware SCA

Is CVE-2019-19709 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-19709: core — Fixed in 1.31.6