NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

ZendFramework potential Cross-site Scripting vector in `Zend_Dojo_View_Helper_Editor`GHSA-j543-vg33-g6vj

MEDIUM

GHSA-j543-vg33-g6vj is a medium-severity (CVSS 6.1) vulnerability in zendframework/zendframework1. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Jun 7, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘zendframework/zendframework1🐘zendframework/zendframework1🐘zendframework/zendframework1

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Zend_Dojo_View_Helper_Editor was incorrectly decorating a TEXTAREA instead of a DIV. The Dojo team has reported that this has security implications as the rich text editor they use is unable to escape content for a TEXTAREA.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzendframework/zendframework1≥ 1.7.0&&< 1.7.91.7.9composer require zendframework/zendframework1:^1.7.9
🐘Packagistzendframework/zendframework1≥ 1.8.0&&< 1.8.51.8.5composer require zendframework/zendframework1:^1.8.5
🐘Packagistzendframework/zendframework1≥ 1.9.0&&< 1.9.71.9.7composer require zendframework/zendframework1:^1.9.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zendframework/zendframework1 to 1.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j543-vg33-g6vj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

`Zend_Dojo_View_Helper_Editor` was incorrectly decorating a TEXTAREA instead of a DIV. The Dojo team has reported that this has security implications as the rich text editor they use is unable to escape content for a TEXTAREA.
O3 Security · Impact-Aware SCA

Is GHSA-j543-vg33-g6vj in your dependencies?

Find it across Packagist, including transitive dependencies.

ZendFramework potential Cross-site Scripting vector in…