Apache ActiveMQ's default configuration doesn't secure the API web contextGHSA-gj5m-m88j-v7c3
HIGHFix: apache/activemq#1201GHSA-gj5m-m88j-v7c3 is a high-severity (CVSS 8.8) CWE-1188 vulnerability in org.apache.activemq:apache-activemq. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.activemq:apache-activemq — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-gj5m-m88j-v7c3.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:apache-activemqReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST API are located). It means that anyone can use these layers without any required authentication. Potentially, anyone can interact with the broker (using Jolokia JMX REST API) and/or produce/consume messages or purge/delete destinations (using the Message REST API).
To mitigate, users can update the default conf/jetty.xml configuration file to add authentication requirement: <bean id="securityConstraintMapping" class="org.eclipse.jetty.security.ConstraintMapping"> <property name="constraint" ref="securityConstraint" /> <property name="pathSpec" value="/" /> </bean>
Or we encourage users to upgrade to Apache ActiveMQ 6.1.2 where the default configuration has been updated with authentication by default.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 6.0.0&&< 6.1.2 | 6.1.2org.apache.activemq:apache-activemq:6.1.2 |
Affected Products
activemqapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:apache-activemq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:apache-activemq to 6.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gj5m-m88j-v7c3 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect GHSA-gj5m-m88j-v7c3
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-gj5m-m88j-v7c3 -u https://target- Template
- Apache ActiveMQ 6.x < 6.1.2 - Broken Access Control
- Severity
- high
- Impact
- Unauthenticated users can interact with the broker, potentially producing, consuming, or deleting messages and accessing sensitive management APIs.
- Remediation
- Upgrade to Apache ActiveMQ 6.1.2 or later, or update `conf/jetty.xml` to require authentication on the `/api/` web context.
Template by ProjectDiscovery nuclei-templates (ChrisJr404), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The vulnerability in Apache ActiveMQ, stemming from insecure default configurations in its Jolokia JMX REST API and Message REST API, poses a critical threat due to the unrestricted access it grants to sensitive administrative functions. Without requiring proper authentication or authorization, malicious actors can…
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-gj5m-m88j-v7c3 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-gj5m-m88j-v7c3 in your dependencies?
Find it across Maven, including transitive dependencies.