CVE-2026-50734 is a high-severity (CVSS 7.5) CWE-789 vulnerability in org.apache.activemq:activemq-client. A fix is available for org.apache.activemq:activemq-client — see the affected versions and patch details below.
Apache ActiveMQ Client, Apache ActiveMQ, Apache ActiveMQ All: Pre-authentication OpenWire memory-allocation DoS during wire format negotiation
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-50734.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:activemq-client☕org.apache.activemq:activemq-client☕org.apache.activemq:apache-activemq☕org.apache.activemq:apache-activemq☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ Client, Apache ActiveMQ, Apache ActiveMQ All.
An unauthenticated network attacker can cause a broker DoS by sending a crafted WireFormatInfo frame with a malicious large size value. The value is not validate and causes the broker to attempt allocation during pre-auth negotiation which can trigger OOM and crash the broker. This issue affects Apache ActiveMQ Client: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-client | all versions | 5.19.8org.apache.activemq:activemq-client:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-client | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-client:6.2.7 |
| ☕Maven | org.apache.activemq:apache-activemq | all versions | 5.19.8org.apache.activemq:apache-activemq:5.19.8 |
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:apache-activemq:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-all | all versions | 5.19.8org.apache.activemq:activemq-all:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-all:6.2.7 |
Affected Products
activemqapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-client to 5.19.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-50734 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A flaw was found in Apache ActiveMQ Classic's OpenWire protocol handling. An unauthenticated remote attacker can crash the broker by sending a crafted WireFormatInfo frame with a malicious oversized value during pre-authentication protocol negotiation, causing an Out of Memory condition. Red Hat AMQ Broker is based on…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-50734 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| AMQ Clients 2026.Q3 | artemis-core-client | RHSA-2026:69459 |
| Red Hat AMQ Broker 7.13.6 | activemq-client | RHSA-2026:66545 |
| Red Hat AMQ Broker 7.14.1 | activemq-client | RHSA-2026:66488 |
Frequently Asked Questions
Is CVE-2026-50734 in your dependencies?
Find it across Maven, including transitive dependencies.