CVE-2015-1830 — activemq-client
Fix: apache/activemq@729c473CVE-2015-1830 is a Path Traversal vulnerability in org.apache.activemq:activemq-client. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.activemq:activemq-client — see the affected versions and patch details below.
Improper Limitation of a Pathname to a Restricted Directory in Apache ActiveMQ
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.activemq:activemq-clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Directory traversal vulnerability in the fileserver upload/download functionality for blob messages in Apache ActiveMQ 5.x before 5.11.2 for Windows allows remote attackers to create JSP files in arbitrary directories via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-client | ≥ 5.0.0&&< 5.11.2 | 5.11.2org.apache.activemq:activemq-client:5.11.2 |
Affected Products
activemqapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache ActiveMQ 5.11.1/5.13.2 - Directory Traversal / Command Execution
by David Jorm · Aug 17, 2015
Apache ActiveMQ 5.x-5.11.1 - Directory Traversal Shell Upload (Metasploit)
by Metasploit · Mar 9, 2020
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-client to 5.11.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1830 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2015-1830 in your dependencies?
Find it across Maven, including transitive dependencies.