CVE-2026-53917 is a high-severity (CVSS 7.5) CWE-789 vulnerability in org.apache.activemq:apache-activemq. A fix is available for org.apache.activemq:apache-activemq — see the affected versions and patch details below.
Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker: Unbounded memory allocation in OpenWire property unmarshalling
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-53917.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:apache-activemq☕org.apache.activemq:apache-activemq☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-client☕org.apache.activemq:activemq-client☕org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-brokerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker.
An authenticated user can cause a broker DoS by sending a crafted OpenWire Message with a large encoded size value for the map. OpenWire message property maps are unmarshaled without size validation which can trigger OOM and crash the broker. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Client: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:apache-activemq | all versions | 5.19.8org.apache.activemq:apache-activemq:5.19.8 |
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:apache-activemq:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-all | all versions | 5.19.8org.apache.activemq:activemq-all:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-all:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-client | all versions | 5.19.8org.apache.activemq:activemq-client:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-client | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-client:6.2.7 |
Affected Products
activemqapacheactivemq brokerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:apache-activemq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:apache-activemq to 5.19.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-53917 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat products ship Apache ActiveMQ Classic components as transitive dependencies. The vulnerability is in the OpenWire message property map unmarshalling code in activemq-client, which does not validate encoded size values, allowing an authenticated attacker to trigger OOM. While AMQ Broker (Artemis) delegates…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-53917 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-53917 in your dependencies?
Find it across Maven, including transitive dependencies.