CVE-2026-54475 is a high-severity (CVSS 7.5) CWE-862 vulnerability in org.apache.activemq:activemq-broker. A fix is available for org.apache.activemq:activemq-broker — see the affected versions and patch details below.
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Temporary destination ownership takeover
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-54475.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-all☕org.apache.activemq:apache-activemq☕org.apache.activemq:apache-activemqReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Missing Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.
Apache ActiveMQ Classic temporary destinations are expected to be isolated to the connection that created them. The isolation can be broken as this is only checked in the client, allowing a different connection to consume from another connection's temporary destination. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-broker | all versions | 5.19.8org.apache.activemq:activemq-broker:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-broker | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-broker:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-all | all versions | 5.19.8org.apache.activemq:activemq-all:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-all:6.2.7 |
| ☕Maven | org.apache.activemq:apache-activemq | all versions | 5.19.8org.apache.activemq:apache-activemq:5.19.8 |
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:apache-activemq:6.2.7 |
Affected Products
activemqapacheactivemq brokerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-broker to 5.19.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-54475 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat products ship Apache ActiveMQ Classic components as transitive dependencies. The vulnerability is in the Classic ActiveMQ broker's temporary destination isolation, where access control is enforced only client-side, allowing a different connection to consume messages from another connection's temporary…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-54475 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-54475 in your dependencies?
Find it across Maven, including transitive dependencies.