CVE-2026-50750 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.apache.activemq:activemq-broker. A fix is available for org.apache.activemq:activemq-broker — see the affected versions and patch details below.
Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Pre-authentication OpenWire DoS following fix for CVE-2026-49270
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-50750.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-broker☕org.apache.activemq:apache-activemq☕org.apache.activemq:apache-activemq☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.
Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7.
Users are recommended to upgrade to version 6.2.7, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-broker | ≥ 5.19.7&&< 5.19.8 | 5.19.8org.apache.activemq:activemq-broker:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-broker | ≥ 6.2.6&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-broker:6.2.7 |
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 5.19.7&&< 5.19.8 | 5.19.8org.apache.activemq:apache-activemq:5.19.8 |
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 6.2.6&&< 6.2.7 | 6.2.7org.apache.activemq:apache-activemq:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 5.19.7&&< 5.19.8 | 5.19.8org.apache.activemq:activemq-all:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 6.2.6&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-all:6.2.7 |
Affected Products
activemqapacheactivemq brokerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-broker to 5.19.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-50750 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat products that include Apache ActiveMQ classic components ship versions prior to 5.19.7 (5.x line) and prior to 6.2.6 (6.x line). The vulnerable code was introduced as a regression in versions 5.19.7 and 6.2.6 while fixing CVE-2026-49270, and is not present in the versions shipped by Red Hat. Products shipping…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-50750 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-50750 in your dependencies?
Find it across Maven, including transitive dependencies.