CVE-2026-49432 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in org.apache.activemq:apache-activemq. A fix is available for org.apache.activemq:apache-activemq — see the affected versions and patch details below.
Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: STOMP negative content-length enables denial of service
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-49432.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:apache-activemq☕org.apache.activemq:apache-activemq☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-stomp☕org.apache.activemq:activemq-stompReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.
A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:apache-activemq | all versions | 5.19.8org.apache.activemq:apache-activemq:5.19.8 |
| ☕Maven | org.apache.activemq:apache-activemq | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:apache-activemq:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-all | all versions | 5.19.8org.apache.activemq:activemq-all:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-all:6.2.7 |
| ☕Maven | org.apache.activemq:activemq-stomp | all versions | 5.19.8org.apache.activemq:activemq-stomp:5.19.8 |
| ☕Maven | org.apache.activemq:activemq-stomp | ≥ 6.0.0&&< 6.2.7 | 6.2.7org.apache.activemq:activemq-stomp:6.2.7 |
Affected Products
activemqapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:apache-activemq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:apache-activemq to 5.19.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-49432 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat products ship Apache ActiveMQ Classic components as transitive dependencies. The vulnerability is in the Classic ActiveMQ STOMP connector's content-length validation, allowing an unauthenticated attacker to cause OOM via a negative content-length value. Apache ActiveMQ Artemis, which powers Red Hat AMQ Broker,…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-49432 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Broker 7.13.6 | artemis-stomp-protocol | RHSA-2026:66545 |
| Red Hat AMQ Broker 7.14.1 | artemis-stomp-protocol | RHSA-2026:66488 |
Frequently Asked Questions
Is CVE-2026-49432 in your dependencies?
Find it across Maven, including transitive dependencies.