CVE-2026-39304 — activemq-client
HIGHCVE-2026-39304 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.apache.activemq:activemq-client. A fix is available for org.apache.activemq:activemq-client — see the affected versions and patch details below.
Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incorrect handling of TLSv1.3 KeyUpdate can be exploited to cause DoS via OOM
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-39304.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:activemq-client☕org.apache.activemq:activemq-client☕org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-all☕org.apache.activemq:activemq-all☕org.apache.activemq:apache-activemq☕org.apache.activemq:apache-activemqReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ.
ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS.
Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4.
Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-client | all versions | 5.19.4org.apache.activemq:activemq-client:5.19.4 |
| ☕Maven | org.apache.activemq:activemq-client | ≥ 6.0.0&&< 6.2.4 | 6.2.4org.apache.activemq:activemq-client:6.2.4 |
| ☕Maven | org.apache.activemq:activemq-broker | all versions | 5.19.4org.apache.activemq:activemq-broker:5.19.4 |
| ☕Maven | org.apache.activemq:activemq-broker | ≥ 6.0.0&&< 6.2.4 | 6.2.4org.apache.activemq:activemq-broker:6.2.4 |
| ☕Maven | org.apache.activemq:activemq-all | all versions | 5.19.4org.apache.activemq:activemq-all:5.19.4 |
| ☕Maven | org.apache.activemq:activemq-all | ≥ 6.0.0&&< 6.2.4 | 6.2.4org.apache.activemq:activemq-all:6.2.4 |
Affected Products
activemqapacheactivemq brokerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-client to 5.19.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-39304 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-39304 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-39304 in your dependencies?
Find it across Maven, including transitive dependencies.