Prevent user enumeration using Guard or the new Authenticator-based SecurityGHSA-5pv8-ppvj-4h68
MEDIUMFix: symfony/symfony@2a581d2GHSA-5pv8-ppvj-4h68 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in symfony/security. A fix is available for symfony/security — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/security🐘symfony/security-guard🐘symfony/security-guard🐘symfony/security-guard🐘symfony/security-core🐘symfony/security-core🐘symfony/security-core🐘lexik/jwt-authentication-bundle+9 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Description
The ability to enumerate users was possible without relevant permissions due to different exception messages depending on whether the user existed or not. It was also possible to enumerate users by using a timing attack, by comparing time elapsed when authenticating an existing user and authenticating a non-existing user.
Resolution
We now ensure that 403s are returned whether the user exists or not if the password is invalid or if the user does not exist.
The patch for this issue is available here for branch 3.4.
Credits
I would like to thank James Isaac and Mathias Brodala for reporting the issue and Robin Chalas for fixing the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/security | ≥ 5.0.0&&< 5.2.8 | 5.2.8composer require symfony/security:^5.2.8 |
| 🐘Packagist | symfony/security-guard | ≥ 2.8.0&&< 3.4.48 | 3.4.48composer require symfony/security-guard:^3.4.48 |
| 🐘Packagist | symfony/security-guard | ≥ 4.0.0&&< 4.4.23 | 4.4.23composer require symfony/security-guard:^4.4.23 |
| 🐘Packagist | symfony/security-guard | ≥ 5.0.0&&< 5.2.8 | 5.2.8composer require symfony/security-guard:^5.2.8 |
| 🐘Packagist | symfony/security-core | ≥ 2.8.0&&< 3.4.48 | 3.4.48composer require symfony/security-core:^3.4.48 |
| 🐘Packagist | symfony/security-core | ≥ 4.0.0&&< 4.4.23 | 4.4.23composer require symfony/security-core:^4.4.23 |
Affected Products
fedorafedoraprojectsymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/security to 5.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5pv8-ppvj-4h68 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-5pv8-ppvj-4h68 in your dependencies?
Find it across Packagist, including transitive dependencies.