NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2015-8125 — symfony

Fix: symfony/symfony#16630

CVE-2015-8125 is a security vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.

Symfony Vulnerable to Timing Attack

Also known asGHSA-g97c-jfx6-xvxh
Published
Updated
Affected
11 pkgs
Patched
11 / 11
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.51%1.35%2.20%3.04%1.0%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

11 pkgs affected
🐘symfony/symfony🐘symfony/symfony🐘symfony/form🐘symfony/form🐘symfony/form🐘symfony/security-http🐘symfony/security-http🐘symfony/security+3 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 might allow remote attackers to have unspecified impact via a timing attack involving the (1) Symfony/Component/Security/Http/RememberMe/PersistentTokenBasedRememberMeServices or (2) Symfony/Component/Security/Http/Firewall/DigestAuthenticationListener class in the Symfony Security Component, or (3) legacy CSRF implementation from the Symfony/Component/Form/Extension/Csrf/CsrfProvider/DefaultCsrfProvider class in the Symfony Form component.

Affected Packages

11 total 11 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/symfony≥ 2.3.0&&< 2.3.352.3.35composer require symfony/symfony:^2.3.35
🐘Packagistsymfony/symfony≥ 2.7.0&&< 2.7.72.7.7composer require symfony/symfony:^2.7.7
🐘Packagistsymfony/form≥ 2.3.0&&< 2.3.352.3.35composer require symfony/form:^2.3.35
🐘Packagistsymfony/form≥ 2.4.0&&< 2.6.122.6.12composer require symfony/form:^2.6.12
🐘Packagistsymfony/form≥ 2.7.0&&< 2.7.72.7.7composer require symfony/form:^2.7.7
🐘Packagistsymfony/security-http≥ 2.4.0&&< 2.6.122.6.12composer require symfony/security-http:^2.6.12

Affected Products

1 product · 54 configurations
Application
symfonysensiolabs
54 versions
2.3.02.3.12.3.22.3.32.3.42.3.52.3.62.3.72.3.82.3.92.3.102.3.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/symfony to 2.3.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8125 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 might allow remote attackers to have unspecified impact via a timing attack involving the (1) Symfony/Component/Security/Http/RememberMe/PersistentTokenBasedRememberMeServices or (2) Symfony/Component/Security/Http/Firewall/DigestAuthenticationListener class in the Symfony Security Component, or (3) legacy CSRF implementation from the Symfony/Component/Form/Extension/Csrf/CsrfProvider/DefaultCsrfProvider class in the Symfony Form component.
O3 Security · Impact-Aware SCA

Is CVE-2015-8125 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-8125: symfony CSRF — Fixed in 2.3.35