NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2013-5958 — symfony

Fix: symfony/polyfill#155

CVE-2013-5958 is a CWE-399 vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.

Symfony Denial of Service Via Long Password Hashing

Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.79%1.58%2.37%0.5%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

9 pkgs affected
🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/polyfill🐘symfony/security🐘symfony/security🐘symfony/security+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/symfony≥ 2.0.0&&< 2.0.252.0.25composer require symfony/symfony:^2.0.25
🐘Packagistsymfony/symfony≥ 2.1.0&&< 2.1.132.1.13composer require symfony/symfony:^2.1.13
🐘Packagistsymfony/symfony≥ 2.2.0&&< 2.2.92.2.9composer require symfony/symfony:^2.2.9
🐘Packagistsymfony/symfony≥ 2.3.0&&< 2.3.62.3.6composer require symfony/symfony:^2.3.6
🐘Packagistsymfony/polyfill≥ 1.0.0&&< 1.10.01.10.0composer require symfony/polyfill:^1.10.0
🐘Packagistsymfony/security≥ 2.0.0&&< 2.0.252.0.25composer require symfony/security:^2.0.25

Affected Products

1 product · 53 configurations
Application
symfonysensiolabs
53 versions
2.0.02.0.12.0.22.0.32.0.42.0.52.0.62.0.72.0.82.0.92.0.102.0.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/symfony to 2.0.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-5958 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.
O3 Security · Impact-Aware SCA

Is CVE-2013-5958 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-5958: symfony DoS — Fixed in 2.0.25