CVE-2018-19790 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in symfony/security-http. A fix is available for symfony/security-http — see the affected versions and patch details below.
Symfony Open Redirect
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security🐘symfony/security+9 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An open redirect was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9 and 4.2.x before 4.2.1. By using backslashes in the _failure_path input field of login forms, an attacker can work around the redirection target restrictions and effectively redirect the user to any domain after login.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/security-http | ≥ 2.7.38&&< 2.7.50 | 2.7.50composer require symfony/security-http:^2.7.50 |
| 🐘Packagist | symfony/security-http | ≥ 2.8.0&&< 2.8.49 | 2.8.49composer require symfony/security-http:^2.8.49 |
| 🐘Packagist | symfony/security-http | ≥ 3.0.0&&< 3.4.20 | 3.4.20composer require symfony/security-http:^3.4.20 |
| 🐘Packagist | symfony/security-http | ≥ 4.0.0&&< 4.0.15 | 4.0.15composer require symfony/security-http:^4.0.15 |
| 🐘Packagist | symfony/security-http | ≥ 4.1.0&&< 4.1.9 | 4.1.9composer require symfony/security-http:^4.1.9 |
| 🐘Packagist | symfony/security-http | ≥ 4.2.0&&< 4.2.1 | 4.2.1composer require symfony/security-http:^4.2.1 |
Affected Products
debian linuxdebianfedorafedoraprojectsymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/security-http to 2.7.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19790 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is CVE-2018-19790 in your dependencies?
Find it across Packagist, including transitive dependencies.