NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Symfony Open RedirectGHSA-89r2-5g34-2g47

MEDIUMFix: symfony/symfony@99a0cec

GHSA-89r2-5g34-2g47 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in symfony/security-http. A fix is available for symfony/security-http — see the affected versions and patch details below.

Also known asCVE-2018-19790
Published
Updated
Affected
17 pkgs
Patched
17 / 17
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.66%1.32%1.98%0.4%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

17 pkgs affected
🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security🐘symfony/security+9 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An open redirect was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9 and 4.2.x before 4.2.1. By using backslashes in the _failure_path input field of login forms, an attacker can work around the redirection target restrictions and effectively redirect the user to any domain after login.

Affected Packages

17 total 17 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/security-http≥ 2.7.38&&< 2.7.502.7.50composer require symfony/security-http:^2.7.50
🐘Packagistsymfony/security-http≥ 2.8.0&&< 2.8.492.8.49composer require symfony/security-http:^2.8.49
🐘Packagistsymfony/security-http≥ 3.0.0&&< 3.4.203.4.20composer require symfony/security-http:^3.4.20
🐘Packagistsymfony/security-http≥ 4.0.0&&< 4.0.154.0.15composer require symfony/security-http:^4.0.15
🐘Packagistsymfony/security-http≥ 4.1.0&&< 4.1.94.1.9composer require symfony/security-http:^4.1.9
🐘Packagistsymfony/security-http≥ 4.2.0&&< 4.2.14.2.1composer require symfony/security-http:^4.2.1

Affected Products

3 products · 8 configurations
OS
debian linuxdebian
1 version
8.0
OS
fedorafedoraproject
1 version
28
Application
symfonysensiolabs
≥ 4.2.0 && < 4.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/security-http to 2.7.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-89r2-5g34-2g47 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

An open redirect was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9 and 4.2.x before 4.2.1. By using backslashes in the `_failure_path` input field of login forms, an attacker can work around the redirection target restrictions and effectively redirect the user to any domain after login.
O3 Security · Impact-Aware SCA

Is GHSA-89r2-5g34-2g47 in your dependencies?

Find it across Packagist, including transitive dependencies.

Symfony Open Redirect (Medium 6.1)