NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2017-11365 — security-core

CRITICALFix: symfony/symfony@878198c

CVE-2017-11365 is a critical-severity (CVSS 9.8) CWE-284 vulnerability in symfony/security-core. A fix is available for symfony/security-core — see the affected versions and patch details below.

Symfony Incorrect Access Control

Also known asGHSA-q87v-q8fw-gmj5
Published
Updated
Affected
12 pkgs
Patched
12 / 12
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.79%1.57%2.35%0.4%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

12 pkgs affected
🐘symfony/security-core🐘symfony/security-core🐘symfony/security-core🐘symfony/security-core🐘symfony/security🐘symfony/security🐘symfony/security🐘symfony/security+4 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Certain Symfony products are affected by: Incorrect Access Control. This affects Symfony 2.7.30 and Symfony 2.8.23 and Symfony 3.2.10 and Symfony 3.3.3. The type of exploitation is: remote. The component is: Password validator.

Affected Packages

12 total 12 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/security-core≥ 2.7.30&&< 2.7.322.7.32composer require symfony/security-core:^2.7.32
🐘Packagistsymfony/security-core≥ 2.8.23&&< 2.8.252.8.25composer require symfony/security-core:^2.8.25
🐘Packagistsymfony/security-core≥ 3.2.10&&< 3.2.123.2.12composer require symfony/security-core:^3.2.12
🐘Packagistsymfony/security-core≥ 3.3.3&&< 3.3.53.3.5composer require symfony/security-core:^3.3.5
🐘Packagistsymfony/security≥ 2.7.30&&< 2.7.322.7.32composer require symfony/security:^2.7.32
🐘Packagistsymfony/security≥ 2.8.23&&< 2.8.252.8.25composer require symfony/security:^2.8.25

Affected Products

1 product · 4 configurations
Application
symfonysensiolabs
4 versions
2.7.302.8.233.2.103.3.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/security-core to 2.7.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-11365 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Certain Symfony products are affected by: Incorrect Access Control. This affects Symfony 2.7.30 and Symfony 2.8.23 and Symfony 3.2.10 and Symfony 3.3.3. The type of exploitation is: remote. The component is: Password validator.
O3 Security · Impact-Aware SCA

Is CVE-2017-11365 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-11365: security-core — Fixed in 2.7.32