CVE-2016-2403 — security-core
CRITICALCVE-2016-2403 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in symfony/security-core. A fix is available for symfony/security-core — see the affected versions and patch details below.
Symfony Authentication Bypass
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/security-core🐘symfony/security-core🐘symfony/security🐘symfony/security🐘symfony/symfony🐘symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/security-core | ≥ 2.8.0&&< 2.8.6 | 2.8.6composer require symfony/security-core:^2.8.6 |
| 🐘Packagist | symfony/security-core | ≥ 3.0.0&&< 3.0.6 | 3.0.6composer require symfony/security-core:^3.0.6 |
| 🐘Packagist | symfony/security | ≥ 2.8.0&&< 2.8.6 | 2.8.6composer require symfony/security:^2.8.6 |
| 🐘Packagist | symfony/security | ≥ 3.0.0&&< 3.0.6 | 3.0.6composer require symfony/security:^3.0.6 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.6 | 2.8.6composer require symfony/symfony:^2.8.6 |
| 🐘Packagist | symfony/symfony | ≥ 3.0.0&&< 3.0.6 | 3.0.6composer require symfony/symfony:^3.0.6 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/security-core to 2.8.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2403 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2016-2403 in your dependencies?
Find it across Packagist, including transitive dependencies.