CVE-2016-4423 is a high-severity (CVSS 7.5) CWE-399 vulnerability in symfony/security-http. A fix is available for symfony/security-http — see the affected versions and patch details below.
Symphony Denial of Service Via Overlong Usernames
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security🐘symfony/security🐘symfony/security🐘symfony/security+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The attemptAuthentication function in Component/Security/Http/Firewall/UsernamePasswordFormAuthenticationListener.php in Symfony before 2.3.41, 2.7.x before 2.7.13, 2.8.x before 2.8.6, and 3.0.x before 3.0.6 does not limit the length of a username stored in a session, which allows remote attackers to cause a denial of service (session storage consumption) via a series of authentication attempts with long, non-existent usernames.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/security-http | ≥ 2.3.0&&< 2.3.41 | 2.3.41composer require symfony/security-http:^2.3.41 |
| 🐘Packagist | symfony/security-http | ≥ 2.4.0&&< 2.7.13 | 2.7.13composer require symfony/security-http:^2.7.13 |
| 🐘Packagist | symfony/security-http | ≥ 2.8.0&&< 2.8.6 | 2.8.6composer require symfony/security-http:^2.8.6 |
| 🐘Packagist | symfony/security-http | ≥ 3.0.0&&< 3.0.6 | 3.0.6composer require symfony/security-http:^3.0.6 |
| 🐘Packagist | symfony/security | ≥ 2.3.0&&< 2.3.41 | 2.3.41composer require symfony/security:^2.3.41 |
| 🐘Packagist | symfony/security | ≥ 2.4.0&&< 2.7.13 | 2.7.13composer require symfony/security:^2.7.13 |
Affected Products
debian linuxdebiansymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/security-http to 2.3.41 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4423 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2016-4423 in your dependencies?
Find it across Packagist, including transitive dependencies.