Mediawiki BotPassword can bypass CentralAuth's account lockGHSA-5c6w-f4w2-2grp
MEDIUMGHSA-5c6w-f4w2-2grp is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in mediawiki/core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mediawiki/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where BotPasswords can bypass CentralAuth's account lock
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.27.0&&< 1.27.5 | 1.27.5composer require mediawiki/core:^1.27.5 |
| 🐘Packagist | mediawiki/core | ≥ 1.29.0&&< 1.29.3 | 1.29.3composer require mediawiki/core:^1.29.3 |
| 🐘Packagist | mediawiki/core | ≥ 1.30.0&&< 1.30.1 | 1.30.1composer require mediawiki/core:^1.30.1 |
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.1 | 1.31.1composer require mediawiki/core:^1.31.1 |
Affected Products
debian linuxdebianmediawikimediawikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.27.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5c6w-f4w2-2grp is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | mediawiki-0:1.27.7-1.el7 | RHSA-2019:3238 |
| Red Hat OpenShift Container Platform 3.11 | mediawiki-0:1.27.7-1.el7 | RHSA-2019:3142 |
| Red Hat OpenShift Container Platform 3.9 | mediawiki123-0:1.23.17-1.el7 | RHSA-2019:3813 |
Frequently Asked Questions
Is GHSA-5c6w-f4w2-2grp in your dependencies?
Find it across Packagist, including transitive dependencies.