NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-0505 — core

MEDIUM

CVE-2018-0505 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in mediawiki/core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mediawiki/core — see the affected versions and patch details below.

Mediawiki BotPassword can bypass CentralAuth's account lock

Also known asGHSA-5c6w-f4w2-2grp
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.82%1.65%2.47%0.4%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where BotPasswords can bypass CentralAuth's account lock

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/core≥ 1.27.0&&< 1.27.51.27.5composer require mediawiki/core:^1.27.5
🐘Packagistmediawiki/core≥ 1.29.0&&< 1.29.31.29.3composer require mediawiki/core:^1.29.3
🐘Packagistmediawiki/core≥ 1.30.0&&< 1.30.11.30.1composer require mediawiki/core:^1.30.1
🐘Packagistmediawiki/core≥ 1.31.0&&< 1.31.11.31.1composer require mediawiki/core:^1.31.1

Affected Products

2 products · 5 configurations
OS
debian linuxdebian
1 version
9.0
Application
mediawikimediawiki
≥ 1.31.0 && < 1.31.1
3 versions
1.27.51.29.31.30.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/core to 1.27.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-0505 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.10mediawiki-0:1.27.7-1.el7RHSA-2019:3238
Red Hat OpenShift Container Platform 3.11mediawiki-0:1.27.7-1.el7RHSA-2019:3142
Red Hat OpenShift Container Platform 3.9mediawiki123-0:1.23.17-1.el7RHSA-2019:3813

Frequently Asked Questions

Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where BotPasswords can bypass CentralAuth's account lock
O3 Security · Impact-Aware SCA

Is CVE-2018-0505 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-0505: core — Fixed in 1.27.5