CVE-2026-33151 — socket.io-parser
Fix: socketio/socket.io@719f9ebCVE-2026-33151 is a Improper Input Validation vulnerability in socket.io-parser. A fix is available for socket.io-parser — see the affected versions and patch details below.
socket.io allows an unbounded number of binary attachments
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33151.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
socket.io-parsernpmDescription
Impact
A specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory.
Patches
| Version range | Used by | Fixed version |
|---|---|---|
>=4.0.0 <4.2.6 | [email protected] and [email protected] | 4.2.6 |
>=3.4.0 <3.4.4 | [email protected] | 3.4.4 |
<3.3.5 | [email protected] | 3.3.5 |
Workarounds
There is no known workaround except upgrading to a safe version.
For more information
If you have any questions or comments about this advisory:
- Open a discussion here
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | socket.io-parser | all versions | 3.3.5npm install socket.io-parser@3.3.5 |
| 📦npm | socket.io-parser | ≥ 3.4.0&&< 3.4.4 | 3.4.4npm install socket.io-parser@3.4.4 |
| 📦npm | socket.io-parser | ≥ 4.0.0&&< 4.2.6 | 4.2.6npm install socket.io-parser@4.2.6 |
Affected Products
socket.io-parsersocketDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for socket.io-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update socket.io-parser to 3.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33151 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-33151 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-33151 in your dependencies?
Find it across npm, including transitive dependencies.