NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

socket.io allows an unbounded number of binary attachmentsGHSA-677m-j7p3-52f9

Fix: socketio/socket.io@719f9eb

GHSA-677m-j7p3-52f9 is a Improper Input Validation vulnerability in socket.io-parser. A fix is available for socket.io-parser — see the affected versions and patch details below.

Also known asCVE-2026-33151
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-677m-j7p3-52f9.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.38%0.75%1.13%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

257other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
socket.io-parsernpm
38.7Mdownloads / week

Description

Impact

A specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory.

Patches

Version rangeUsed byFixed version
>=4.0.0 <4.2.6[email protected] and [email protected]4.2.6
>=3.4.0 <3.4.4[email protected]3.4.4
<3.3.5[email protected]3.3.5

Workarounds

There is no known workaround except upgrading to a safe version.

For more information

If you have any questions or comments about this advisory:

  • Open a discussion here

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmsocket.io-parserall versions3.3.5npm install socket.io-parser@3.3.5
📦npmsocket.io-parser≥ 3.4.0&&< 3.4.43.4.4npm install socket.io-parser@3.4.4
📦npmsocket.io-parser≥ 4.0.0&&< 4.2.64.2.6npm install socket.io-parser@4.2.6

Affected Products

1 product · 3 configurations
Application
socket.io-parsersocket
≥ 4.0.0 && < 4.2.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for socket.io-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update socket.io-parser to 3.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-677m-j7p3-52f9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for GHSA-677m-j7p3-52f9 (CC BY 4.0)

Frequently Asked Questions

### Impact A specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. ### Patches | Version range | Used by | Fixed version | |------------------|--------------------------------------------|---------------| | `>=4.0.0 <4.2.6` | `[email protected]` and `[email protected]` | `4.2.6` | | `>=3.4.0 <3.4.4` | `[email protected]` | `3.4.4` | | `<3.3.5` | `[email protected]` |
O3 Security · Impact-Aware SCA

Is GHSA-677m-j7p3-52f9 in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-677m-j7p3-52f9: socket.io-parser — Fixed in 3.3.5