NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2020-36049 — socket.io-parser

HIGHFix: socketio/socket.io-parser@dcb942d

CVE-2020-36049 is a high-severity (CVSS 7.5) CWE-770 vulnerability in socket.io-parser. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for socket.io-parser — see the affected versions and patch details below.

Resource exhaustion in socket.io-parser

Also known asGHSA-xfhh-g9f5-x4m4
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.10%2.21%3.31%0.5%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

257other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
socket.io-parsernpm
38.7Mdownloads / week

Description

The socket.io-parser npm package before versions 3.3.2 and 3.4.1 allows attackers to cause a denial of service (memory consumption) via a large packet because a concatenation approach is used.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmsocket.io-parserall versions3.3.2npm install socket.io-parser@3.3.2
📦npmsocket.io-parser≥ 3.4.0&&< 3.4.13.4.1npm install socket.io-parser@3.4.1

Affected Products

1 product · 1 configurations
Application
socket.io-parsersocket
< 3.4.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for socket.io-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update socket.io-parser to 3.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-36049 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The `socket.io-parser` npm package before versions 3.3.2 and 3.4.1 allows attackers to cause a denial of service (memory consumption) via a large packet because a concatenation approach is used.
O3 Security · Impact-Aware SCA

Is CVE-2020-36049 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-36049: socket.io-parser DoS — Fixed in 3.3.2